Become a ltxtech.com member, Click here to register!
American Powerhouse

Page 4 of 4 FirstFirst 1234
Results 31 to 37 of 37
  1. #31
    Founding Member


    Status
    Offline
    Join Date
    Sep 2008
    Name
    Jay
    Vehicle
    93 Ultra Z
    Location
    Delaware
    Posts
    3,134

    Default

    i pulled a spark plug and man does it look bad. Black, oily, smelly... I know it is running rich AF but it still seems like it is not getting enough fire. I put the opti on about 1+ years ago. It is a Delco. It sat for over a year before i messed with the car to get it to DMV. I really would love to to the TorqueHead 24x link. I know the 1992/3 kit was "coming soon" so I emailed them.. no reply ...

  2. #32
    Founding Member


    Status
    Offline
    Join Date
    Sep 2008
    Name
    Jay
    Vehicle
    93 Ultra Z
    Location
    Delaware
    Posts
    3,134

    Default

    .

  3. #33
    Founding Member


    Status
    Offline
    Join Date
    Sep 2008
    Name
    Jay
    Vehicle
    93 Ultra Z
    Location
    Delaware
    Posts
    3,134

    Default

    Quote Originally Posted by Injuneer View Post
    What air box are you using, the one from SLP that came with the hood?
    yes, the SLP one

  4. #34
    Founding Member


    Status
    Offline
    Join Date
    Sep 2008
    Name
    Jay
    Vehicle
    93 Ultra Z
    Location
    Delaware
    Posts
    3,134

    Default

    Quote Originally Posted by Injuneer View Post
    Test IAC electronics:

    From Shoebox

    http://shbox.com/1/iac2.jpg

    Passages could be plugged. I remember one we sorted out where the coolant in the bottom plate had leaked into the air passage.
    I tested the IAC and it tested good. I bypassed the coolant to the TB. I also cleaned the passages.. I've been out here in the shop since 5 AM reading my service manual and trying everything I can think of.. LOL I am thinking low spark energy could be the problem?

  5. #35
    Pr0jekt Turb0?


    Status
    Offline
    Join Date
    Sep 2008
    Name
    Ryan
    Vehicle
    1993 Camaro Z28
    Location
    Utica, NY + Jacksonville, FL
    Posts
    3,518

    Default

    I had an IAC that was reading fine from a datalog standpoint but when I removed it from the TB, it was caked in carbon and the spring was completely stuck. As it was stuck open, the PCM was just dumping fuel. Not sure if it is relatable, but worth checking.
    -Ryan
    93 Z28 M28

    Mod List



  6. #36
    Founding Member


    Status
    Offline
    Join Date
    Sep 2008
    Name
    Jay
    Vehicle
    93 Ultra Z
    Location
    Delaware
    Posts
    3,134

    Default

    Quote Originally Posted by Z28pr0jekt View Post
    I had an IAC that was reading fine from a datalog standpoint but when I removed it from the TB, it was caked in carbon and the spring was completely stuck. As it was stuck open, the PCM was just dumping fuel. Not sure if it is relatable, but worth checking.
    the IAC was clean and i tried a new in box one too. This car hates me... I have a spare opti module. The plugs i took out so far look pretty bad. Ill pull this MF opti one more time and fix it. If it does not solve the problem, LSX here i come! :-P

  7. #37
    "The Rock"


    Status
    Offline
    Join Date
    Jul 2009
    Vehicle
    1996 Camaro Z28, 1994 Trans Am GT, 1985/1996 Corvette CLONE
    Location
    Shillington, Pennsylvania, United States
    Posts
    60,990

    Default

    Quote Originally Posted by jaysz2893 View Post
    .... If it does not solve the problem, LSX here i come! :-P
    Blasphemy

    LTXtexh.com is my drug...


    Our BIG MOMENT @ the 2012 LTXshootout

    http://www.facebook.com/photo.php?v=521756391174175

    1996 Camaro Z28: RIP 09/25/2016

    1994 Trans Am GT: SOLD 05/2017

    1985/1996GS clone: SOLD

    1996 Impala SS H/C, LT, with true dual exhaust, 4.10s, lowered, with CPT trans, many cosmetic mods, and a whole lot more to come...

    2002 Caddilac EscaladeL CAI, lowered, 6.0 , AWD..





Page 4 of 4 FirstFirst 1234

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •