Become a ltxtech.com member, Click here to register!
Shootout

Results 1 to 2 of 2
  1. #1
    LTX Regular


    Status
    Offline
    Join Date
    Feb 2014
    Name
    Chris
    Vehicle
    1995 Mystic z28
    Posts
    433

    Default Video- running after cam

    Here ya gohttps://photos.app.goo.gl/AaIa4YmIgyfsKiE23



    Finally got it running somewhat consistently after the cam swap. I think all sensors are new along with plugs etc. The MAP actually went bad which was quite a surprise.

    Time for a tune and installation of new interior.
    Last edited by donfrye; 05-21-2018 at 09:51 PM.
    95 Mystic Z28, 17x9 FR, 17x11 RR ZR-1's, Pacesetter LT's and Y-pipe, Borla adjustable, Moroso CAI, 2800 Stall, AC Delete, and Cracked Dash/broken lid Mod.

  2. The Following 2 Users Say Thank You to donfrye For This Post:


  3. #2
    Xtreme Member


    Status
    Offline
    Join Date
    Nov 2012
    Name
    Shaun
    Vehicle
    1994 camaro
    Location
    Lehigh Valley PA
    Posts
    6,033

    Default

    Quote Originally Posted by donfrye View Post
    Here ya gohttps://photos.app.goo.gl/AaIa4YmIgyfsKiE23



    Finally got it running somewhat consistently after the cam swap. I think all sensors are new along with plugs etc. The MAP actually went bad which was quite a surprise.

    Time for a tune and installation of new interior.
    sounds healthy, good job

    Sent from my SM-N950U using Tapatalk
    2009 G8 GXP #871 - Stock and faster than my LT1

    1994 Z28 T56 - Le2 H/C, SBE, Hooker lt's, some rod ended suspension stuff, and a whole lotta tetanus

    The wrench for LTConvert's 94 Z28- Ellwein 383/LE Trickflows/ P600B/ CPT Pro Race/Pro Torque 3200

  4. The Following User Says Thank You to Tubby Z28 For This Post:


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •