• Brandon++S's Avatar
    08-08-2020, 07:49 PM
    Brandon++S replied to a thread 02 sensor in LTx Engine Tech
    If I unplug the crank sensor and it is not tuned out, will it throw codes or die or anything? Sent from my SM-G930V using Tapatalk
    22 replies | 522 view(s)
  • Brandon++S's Avatar
    08-08-2020, 07:17 PM
    Brandon++S replied to a thread 02 sensor in LTx Engine Tech
    I have heard the same things, unfortunately when I had it tuned that was who I saw. I guess I will start with plugs, wires, coil and then last the...
    22 replies | 522 view(s)
  • Brandon++S's Avatar
    08-08-2020, 06:29 PM
    Brandon++S replied to a thread 02 sensor in LTx Engine Tech
    IAC was crudded up badly. Cleaned as you suggested and idle seems to be fine now. Now on to the stumble. It is definitely missing but clears up...
    22 replies | 522 view(s)
  • Brandon++S's Avatar
    08-01-2020, 05:05 PM
    Brandon++S replied to a thread 02 sensor in LTx Engine Tech
    So. I'm getting 53ohms according to the test , so electrical checks out. Should I remove it and clean or is there a way to leave it in and clean....
    22 replies | 522 view(s)
  • Brandon++S's Avatar
    07-28-2020, 07:49 PM
    Brandon++S replied to a thread 02 sensor in LTx Engine Tech
    Ok. Thanks Sent from my SM-G930V using Tapatalk
    22 replies | 522 view(s)
  • Brandon++S's Avatar
    07-28-2020, 06:45 PM
    Brandon++S replied to a thread 02 sensor in LTx Engine Tech
    Ok. Will test and clean then report back. Not going to be the cause of stumbling though correct? I'm guessing I have 2 problems going on? Sent...
    22 replies | 522 view(s)
  • Brandon++S's Avatar
    07-24-2020, 02:00 PM
    Brandon++S replied to a thread 02 sensor in LTx Engine Tech
    Idle is not bad on start up, but when turning the steering wheel it starts idling down to the point of stalling. The plugs I believe are on the same...
    22 replies | 522 view(s)
  • Brandon++S's Avatar
    07-24-2020, 11:52 AM
    Brandon++S replied to a thread 02 sensor in LTx Engine Tech
    About 2 weeks 4years No codes 1000 rpm 227/235 Around 2000. Shakes pretty bad 3200 miles Tr55 .045 2 black looking, but not wet 6 years
    22 replies | 522 view(s)
  • Brandon++S's Avatar
    07-24-2020, 08:05 AM
    Brandon++S replied to a thread 02 sensor in LTx Engine Tech
    Could this be the opti or the coil? Sent from my SM-G930V using Tapatalk
    22 replies | 522 view(s)
  • Brandon++S's Avatar
    07-21-2020, 08:58 PM
    Brandon++S replied to a thread 02 sensor in LTx Engine Tech
    Ok, I need help. Rpms are dropping to 500 or less and sometimes engine stalls when stopping at red light etc. It used to idle a little high when...
    22 replies | 522 view(s)
  • Brandon++S's Avatar
    07-21-2020, 08:43 AM
    How did you do your 2 step with the t56? Sent from my SM-G930V using Tapatalk
    493 replies | 24402 view(s)
  • Brandon++S's Avatar
    07-14-2020, 07:06 PM
    Love the emblem! Sent from my SM-G930V using Tapatalk
    1119 replies | 121730 view(s)
  • Brandon++S's Avatar
    07-13-2020, 08:01 PM
    Brandon++S replied to a thread 02 sensor in LTx Engine Tech
    Ok. Will do. Thanks for the response! Sent from my SM-G930V using Tapatalk
    22 replies | 522 view(s)
No More Results
About Brandon++S

Basic Information

About Brandon++S
Biography:
97 Z28.After many years finally back on the road. LE heads and cam,long tubes, M6. Always liked the LT1, even more so since it seems to be the underdog...lol
Name:
Brandon++S
Location:
Alabama
Vehicle:
1997 camaro z28
Interests:
cars

Statistics


Total Posts
Total Posts
161
Posts Per Day
0.09
General Information
Last Activity
Today 07:56 AM
Join Date
09-06-2015
Referrals
0
No results to display...
No results to display...
iTrader Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
Submit Feedback For Brandon++S
View Complete Feedbacks for Brandon++S
  Past
Month
Past
6 Months
Past
12 Months
  0 0 0
  0 0 0
  0 0 0